Codeup墓地 Contest100000575 问题 E: Shortest Distance

题目描述

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

输入

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D1 … DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

输出

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

样例输入

5 1 2 4 14 9
3
1 3
2 5
4 1

样例输出

3
10
7

代码:

#include<cstdio>
int main(){
	int N,M,a,b,total=0;//total记录总距离 
	scanf("%d",&N);
	int exits[N];//存放各段距离 
	for(int i=0;i<N;++i){
		scanf("%d",&exits[i]);
		total+=exits[i];
	}
	scanf("%d",&M);
	for(int i=0;i<M;++i){
		scanf("%d%d",&a,&b);
		int left=a<b?a-1:b-1,right=a>b?a-1:b-1,distance=0;
		for(int i=left;i<right;++i) distance+=exits[i];//a、b区间内的距离 
		distance=distance<total-distance?distance:total-distance;//最小距离 
		printf("%d\n",distance);
	}
	return 0;
}

在这里插入图片描述

猜你喜欢

转载自blog.csdn.net/qq_37205425/article/details/85062208