算法笔记——Codeup Contest 100000575 Problem E Shortest Distance (20)

题目描述
The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.
输入
Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 … DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.
输出
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
样例输入
5 1 2 4 14 9
3
1 3
2 5
4 1
样例输出
3
10
7

代码

#include <cstdio>
#define maxn 100010							//最大出口数不超过100010 
#include <algorithm>						//取顺时针距离和逆时针距离中较小者输出 min函数 
using namespace std; 
int main () {
	int n,m,x,y,temp,a[maxn]={0} ;			//分别记录 出口数、录入出口对数、出口对的两头、数组a记录从1到其他出口的逆时针距离 
	scanf ("%d", &n) ;
	for (int i=1; i<=n; i++) {
		scanf ("%d", &temp) ;	
		a[i+1] = a[i]+temp ;				//得到a[2]到a[n+1]的值 加上初始数组为0 所以a[1]为0 
	}
	int total = a[n+1] ;					//total记录逆时针一圈的总路程 
	scanf ("%d", &m) ;	
	while (m--) {							//进行m次出口对之间距离的判断 
		int ans;
		scanf ("%d %d", &x, &y) ;			 
		if (x > y) {
			int e=x;
			x=y;
			y=e;					
		}									//交换 使得 x<=y 
		ans = min(total-a[y]+a[x], a[y]-a[x] );		//顺时针距离 逆时针距离 取小 
		printf ("%d\n", ans) ;				//输出 
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/arthur01p/article/details/86541342