并查集(A - Friendship)

Description

A friend is like a flower,
a rose to be exact,
Or maybe like a brand new gate
that never comes unlatched.

A friend is like an owl,
both beautiful and wise.
Or perhaps a friend is like a ghost,
whose spirit never dies.

A friend is like a heart that goes
strong until the end.
Where would we be in this world
if we didn't have a friend?

                       - By Emma Guest

Now you've grown up, it's time to make friends. The friends you make in university are the friends you make for life. You will be proud if you have many friends.

Input

There are multiple test cases for this problem.

Each test case starts with a line containing two integers N, M (1 <= N <= 100'000, 1 <= M <= 200'000), representing that there are totally N persons (indexed from 1 to N) and M operations, then M lines with the form "M a b" (without quotation) or "Q a" (without quotation) follow. The operation "M a b" means that person a and b make friends with each other, though they may be already friends, while "Q a" means a query operation.

Friendship is transitivity, which means if a and b, b and c are friends then a and c are also friends. In the initial, you have no friends except yourself, when you are freshman, you know nobody, right? So in such case you have only one friend.

Output

For each test case, output "Case #:" first where "#" is the number of the case which starts from 1, then for each query operation "Q a", output a single line with the number of person a's friends.

Separate two consecutive test cases with a blank line, but Do NOT output an extra blank line after the last one.

扫描二维码关注公众号,回复: 4972251 查看本文章

Sample Input

3 5
M 1 2
Q 1
Q 3
M 2 3
Q 2
5 10
M 3 2
Q 4
M 1 2
Q 4
M 3 2
Q 1
M 3 1
Q 5
M 4 2
Q 4

Sample Output

Case 1:
2
1
3

Case 2:
1
1
3
1
4

Notes

This problem has huge input and output data, please use 'scanf()' and 'printf()' instead of 'cin' and 'cout' to avoid time limit exceed.

自己敲了一上午也没过,最后参考的同学的代码

#include<stdio.h>
#include<string.h>
int pre[100110],count[100110],r;
int find(int x)
{
    while(x!=pre[x])
    x=pre[x];
    return x;
}
void merge(int x,int y)
{
    int fx,fy;
    fx=find(x);
    fy=find(y);
    if(fx==fy)
    return;
    if(count[fx]<count[fy])
    {
        r=fx;
        fx=fy;//把小的合并到大的上面;
        fy=r;
    }
       pre[fy]=fx;
       count[fx]=count[fx]+count[fy];
}
int main()
{
    int i,j,m,n,c,d,e,k=1;
    char a[10];
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(k!=1)
        printf("\n");//值得学习
        printf("Case %d:\n",k++);
        for(j=1;j<=n;j++)
        {
           pre[j]=j;
           count[j]=1;
        }
        for(i=0;i<m;i++)
        {
            scanf("%s",&a);
            if(a[0]=='M')
            {
                scanf("%d%d",&c,&d);
                merge(c,d);
            }
            else
            {
                scanf("%d",&e);
                printf("%d\n",count[find(e)]);
            }
        }
    }
    return 0;
}


 

猜你喜欢

转载自blog.csdn.net/u013514659/article/details/19921463