sdut oj C语言 水仙花数

版权声明:本人原创文章若需转载请标明出处和作者!沙沙 https://blog.csdn.net/weixin_44143702/article/details/86526481

水仙花数

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

春天是鲜花的季节,水仙花就是其中最迷人的代表,数学上有个水仙花数,是这样定义的: 
“水仙花数”是指一个三位数,它的各位数字的立方和等于其本身,比如:153=13+53+33。
现在要求输出所有在m和n范围内的水仙花数。

Input

输入数据有多组,每组占一行,包括两个整数m和n(100<=m<=n<=999)。

Output

对于每个测试实例,要求输出所有在给定范围内的水仙花数,就是说,输出的水仙花数必须大于等于m,并且小于等于n,如果有多个,则要求从小到大排列在一行内输出,之间用一个空格隔开;
如果给定的范围内不存在水仙花数,则输出no;
每个测试实例的输出占一行。

Sample Input

100 120
300 380

Sample Output

no
370 371
#include <stdio.h>
#include<stdlib.h>
#include<math.h>
int main()
{
    int m, n, count, i, sum, t;
    sum = 0;
    while(~scanf("%d %d", &m, &n))
    {
        count = 0;
        for(; m <= n; m++)
        {
            i = m;
            sum = 0;
            for(t = 0; i > 0; i /= 10)
            {
                t = i % 10;
                sum += t * t * t;
            }
            if(sum == m)
            {
                if(count == 0)
                {
                    printf("%d", m);
                    count++;
                }
                else
                {
                    printf(" %d", m);
                    count++;
                }
            }
        }
        if(count == 0)
        {
            printf("no");
        }
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_44143702/article/details/86526481