hdu-1907 John

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1907

John

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 6227    Accepted Submission(s): 3627

 

Problem Description

Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.
 

Input

The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:
1 <= T <= 474,
1 <= N <= 47,
1 <= Ai <= 4747
 

Output

Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.
 

Sample Input

2 
3 
3 5 1 
1 
1

Sample Output

John 
Brother

题目意思;两个人可分别取糖果(1-n),谁取走最后一个,谁就输了。

思路:尼姆博弈,再特判1就行了。

#include <iostream>
#include <algorithm>
using namespace std;
int arr[48];
int main()
{
    int t,n,i,temp;
    cin>>t;
    while( t-- )
    {
        cin>>n;
        for(i=0;i<n;++i)
            cin>>arr[i];
        sort(arr,arr+n);
        // 如果全是1,按照奇偶判断谁获胜
        if( arr[n-1]==1 )
        {
            if( n&1 )   cout<<"Brother"<<endl;
            else    cout<<"John"<<endl;
            continue;
        }
        // 异或加起来
        temp=arr[0]^arr[1];
        for(i=2;i<n;++i)
            temp^=arr[i];
        if( temp==0 )   cout<<"Brother"<<endl;
        else    cout<<"John"<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41515833/article/details/86565047