寒假训练营第四天(STL入门)D题:排序

D题:排序(sort)

今天的上机考试虽然有实时的Ranklist,但上面的排名只是根据完成的题数排序,没有考虑 每题的分值,所以并不是最后的排名。给定录取分数线,请你写程序找出最后通过分数线的 考生,并将他们的成绩按降序打印。

Input
测试输入包含若干场考试的信息。每场考试信息的第1行给出考生人数N ( 0 < N
< 1000 )、考题数M ( 0 < M < = 10 )、分数线(正整数)G;第2行排序给出第1题至第M题的正整数分值;以下N行,每行给出一 名考生的准考证号(长度不超过20的字符串)、该生解决的题目总数m、以及这m道题的题号 (题目号由1到M)。 当读入的考生人数为0时,输入结束,该场考试不予处理。

Output
对每场考试,首先在第1行输出不低于分数线的考生人数n,随后n行按分数从高 到低输出上线考生的考号与分数,其间用1空格分隔。若有多名考生分数相同,则按他们考
号的升序输出。

Sample Input
4 5 25
10 10 12 13 15
CS004 3 5 1 3
CS003 5 2 4 1 3 5
CS002 2 1 2
CS001 3 2 3 5
1 2 40
10 30
CS001 1 2
2 3 20
10 10 10
CS000000000000000001 0
CS000000000000000002 2 1 2
0

Sample Output
3
CS003 60
CS001 37
CS004 37
0
1
CS000000000000000002 20

Hint
Huge input, scanf is recommended.

题意:由于本人还是小白,正在不断努力,这道题可以明确是采用sort排序,重点是要利用结构体,通过sort对结构体排序;
首先我的代码如下:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
struct student
{
    char a[20];
    int b;
    int c[10];
    int grade;
} stu[1000];
bool cmp(student m,student n)
{
    if(m.grade!=n.grade)
        return m.grade>n.grade;
    else
        return strcmp(m.a,n.a)<0;
}
int main()
{
    int N,M,G;
    while(~scanf("%d",&N))
    {
        if(N==0)
            break;
        scanf("%d%d",&M,&G);
        int x[10],i,j;
        for(i=1; i<=M; i++)
        {
            scanf("%d",&x[i]);
        }
        for(i=0; i<N; i++)
        {
            scanf("%s%d",&stu[i].a,&stu[i].b);
            stu[i].grade=0;
            for(j=0; j<stu[i].b; j++)
            {
                int temp;
                scanf("%d",&temp);
                stu[i].c[j]=temp;
                stu[i].grade+=x[temp];
            }
        }
        sort(stu,stu+N,cmp);
        for(i=0; i<N; i++)
        {
            if(stu[i].grade>=G)
                continue;
            else
                break;
        }
        printf("%d\n",i);
        for(j=0; j<N; j++)
        {
            if(stu[j].grade>=G)
                printf("%s %d\n",stu[j].a,stu[j].grade);
        }
    }
    return 0;
}

大家看到首先就应该可能想到结果,没错结果WA了,看上去貌似没毛病吧,但是在向学长寻求帮助后,发现在定义数组时,我们应该把数组稍微比题意的调大一些
于是修改后的代码如下(AC):

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
struct student
{
    char a[25];
    int b;
    int c[15];
    int grade;
} stu[1000];
bool cmp(student m,student n)
{
    if(m.grade!=n.grade)
        return m.grade>n.grade;
    else
        return strcmp(m.a,n.a)<0;
}
int main()
{
    int N,M,G;
    while(~scanf("%d",&N))
    {
        if(N==0)
            break;
        scanf("%d%d",&M,&G);
        int x[15],i,j;
        for(i=1; i<=M; i++)
        {
            scanf("%d",&x[i]);
        }
        for(i=0; i<N; i++)
        {
            scanf("%s%d",&stu[i].a,&stu[i].b);
            stu[i].grade=0;
            for(j=0; j<stu[i].b; j++)
            {
                int temp;
                scanf("%d",&temp);
                stu[i].c[j]=temp;
                stu[i].grade+=x[temp];
            }
        }
        sort(stu,stu+N,cmp);
        for(i=0; i<N; i++)
        {
            if(stu[i].grade>=G)
                continue;
            else
                break;
        }
        printf("%d\n",i);
        for(j=0; j<N; j++)
        {
            if(stu[j].grade>=G)
                printf("%s %d\n",stu[j].a,stu[j].grade);
        }
    }
    return 0;
}

小白之旅还很长,每天不断进步,今天看到这句话很喜欢,人一我百,人十我万

猜你喜欢

转载自blog.csdn.net/boliu147258/article/details/86632693