1009 Product of Polynomials(25)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6
#include<cstdio>
int main()
{
	int K1,K2,count=0;
	int ex1,ex2;
	double co1,co2;
	double P[1001]={0};
	double C[2001]={0};
	scanf("%d",&K1);
	for(int i=0;i<K1;i++) 
	{
		scanf("%d %lf",&ex1,&co1);
		P[ex1]=co1;//存第一个多项式 
		
	}
	scanf("%d",&K2);
	for(int i=0;i<K2;i++) 
	{
		scanf("%d %lf",&ex2,&co2);
		for(int j=0;j<1001;j++)
		{	
			if(P[j]!=0)
				C[ex2+j]+=(P[j]*co2);
		} 
	}
	for(int i=0;i<2001;i++)
	{
		if(C[i]!=0)count++;
	}
	printf("%d",count);
	for(int i=2000;i>=0;i--)
	{
		if(C[i]!=0)printf(" %d %.1f",i,C[i]);
	}
	return 0;
}

emm直接照着上一题改的..比较蠢

猜你喜欢

转载自blog.csdn.net/nishigesb123/article/details/83245880