1009 Product of Polynomials (25分)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000. 

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place. 

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6
#include<iostream>
#include<iomanip>
using namespace std;

int main(){

    int k1,k2;
    int exp1,exp2;
    double coe1,coe2;
    double p1[2200] = {};
    double p2[2200] = {};
    double p[2200] = {};

 
    cin >> k1;
    for(int i = 0; i < k1; i++){
        
        cin >> exp1 >> coe1;
        p1[exp1] = coe1;

    }

    cin >> k2;

    for(int i = 0; i < k2; i++){
        
        cin >> exp2 >> coe2;

        p2[exp2] = coe2;

    }




    for(int i = 0; i < 1001; i++){

        for(int j = 0; j < 1001; j++){
             if(p1[i] && p2[j])

                p[i + j] += p1[i] * p2[j];

            

        }
    }

    int count = 0;
    for(int i = 0; i < 2002; i++){
        
        if(p[i] != 0)
            count++;

    }




    printf("%d", count);
    for(int i = 2002; i >= 0; i--){
        
        if(p[i] != 0){

            printf(" %d %.1lf",i, p[i]);
        }
            

    }



    return 0;
}
发布了11 篇原创文章 · 获赞 0 · 访问量 75

猜你喜欢

转载自blog.csdn.net/zbchenchanghao/article/details/103932349