1009 Product of Polynomials (25)(25 分)

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 a~N1~ N2 a~N2~ ... NK a~NK~, where K is the number of nonzero terms in the polynomial, Ni and a~Ni~ (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 3 3.6 2 6.0 1 1.6

 对了俩个测试点,感觉这个测试数据也严厉了吧

#include<bits/stdc++.h>
using namespace std;

int a1[1000],a2[1000];
double b1[1000],b2[1000];
double s[10000];
int main()
{
    int k1,k2;
    cin>>k1;
    for(int i=0;i<k1;i++){
        cin>>a1[i]>>b1[i];
    }
    cin>>k2;
    for(int i=0;i<k2;i++){
        cin>>a2[i]>>b2[i];
    }
    for(int i=0;i<k1;i++){
        for(int j=0;j<k2;j++){
            int c=a1[i]+a2[j];
            s[c]+=b1[i]*1.0*b2[j];
        }
    }
    int flag=0;
    vector<pair<int,double> >Q;
    for(int i=0;i<100;i++){
        if(s[i]){
            flag++;
            Q.push_back(make_pair(i,s[i]));
        }
    }
    sort(Q.begin(),Q.end());
    reverse(Q.begin(),Q.end());
    cout<<flag<<" ";
    vector<pair<int,double> >::iterator it;
    cout<<fixed;
    cout<<setprecision(1);
    int f=0;
    for(it=Q.begin();it!=Q.end();++it){
        if(f) cout<<" ";
        cout<<it->first<<" "<<it->second;
        f=1;
    }
    cout<<endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Wchenchen0/article/details/81394494