Everything Has Changed ( HDU 6354 )

版权声明:转载时 别忘了注明出处 https://blog.csdn.net/ZCY19990813/article/details/89854677

Description

Edward is a worker for Aluminum Cyclic Machinery. His work is operating mechanical arms to cut out designed models. Here is a brief introduction of his work. 
Assume the operating plane as a two-dimensional coordinate system. At first, there is a disc with center coordinates (0,0)(0,0) and radius RR. Then, mm mechanical arms will cut and erase everything within its area of influence simultaneously, the ii-th area of which is a circle with center coordinates (xi,yi)(xi,yi) and radius riri (i=1,2,⋯,m)(i=1,2,⋯,m). In order to obtain considerable models, it is guaranteed that every two cutting areas have no intersection and no cutting area contains the whole disc. 
Your task is to determine the perimeter of the remaining area of the disc excluding internal perimeter. 
Here is an illustration of the sample, in which the red curve is counted but the green curve is not. 

Input

The first line contains one integer TT, indicating the number of test cases. 
The following lines describe all the test cases. For each test case: 
The first line contains two integers mm and RR. 
The ii-th line of the following mm lines contains three integers xi,yixi,yi and riri, indicating a cutting area. 
1≤T≤10001≤T≤1000, 1≤m≤1001≤m≤100, −1000≤xi,yi≤1000−1000≤xi,yi≤1000, 1≤R,ri≤10001≤R,ri≤1000 (i=1,2,⋯,m)(i=1,2,⋯,m).

Output

For each test case, print the perimeter of the remaining area in one line. Your answer is considered correct if its absolute or relative error does not exceed 10−610−6. 
Formally, let your answer be aa and the jury's answer be bb. Your answer is considered correct if |a−b|max(1,|b|)≤10−6|a−b|max(1,|b|)≤10−6. 

Sample Input

1
4 10
6 3 5
10 -4 3
-2 -4 4
0 9 1 
 
Sample Output

81.62198908430238475376 

题意:求红色的周长。

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <sstream>
#include <cstdio>
#include <vector>
#include <string>
#include <cmath>
#include <stack>
#include <queue>
#include <map>
#include <set>
#define MAX 0x3f3f3f3f
#define fori(a,b) for(int i=a;i<=b;i++)
#define forj(a,b) for(int j=a;j<=b;j++)
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
typedef long long ll;
const double PI = acos(-1);
const int M=1e6+10;
const int mod=1e9+7;
int main()
{
    int i,j,T,m;
    double r,R,x,y;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d %lf",&m,&R);
        double ans=2.0*PI*R;
        while(m--){
            scanf("%lf%lf%lf",&x,&y,&r);
            double d=sqrt(x*x + y*y);
            if(R-r == d){//内切
                ans+= 2.0*PI*r;
            }
            else if(R-r<d && R+r>d){
                double d1;//大圆的弦心距
                d1=(double)(R*R-r*r+d*d)/(2.0*d);
                ans-=2.0*R*acos(d1/R);
                ans+=2.0*r*acos((d-d1)/r);
            }
        }
        printf("%.20lf\n",ans);
    }

猜你喜欢

转载自blog.csdn.net/ZCY19990813/article/details/89854677
今日推荐