(6月好好待我吧~~~)1046 Shortest Distance (20 分)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10​5​​]), followed by N integer distances D​1​​ D​2​​ ⋯ D​N​​, where D​i​​ is the distance between the i-th and the (i+1)-st exits, and D​N​​is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10​4​​), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10​7​​.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7
#include<iostream>
#include<vector>
using namespace std;
int main()
{
    int n;
    cin>>n;
    vector<int>dis(n+1);
    int sum=0,left,right,cnt;
    for(int i=1;i<=n;i++)
    {
        int temp;
        cin>>temp;
        sum+=temp;
        dis[i]=sum;///存储距离和
    }
///dis[0]=0,dis[1]=1,dis[2]=3,dis[3]=7,dis[4]=21,dis[5]=30;
    cin>>cnt;
    for(int i=0;i<cnt;i++)
    {
        cin>>left>>right;
        if(left>right)
        swap(left,right);///始终保持左边小于右边
        int temp=dis[right-1]-dis[left-1];///求差值
        cout<<min(temp,sum-temp)<<endl;///正反对比找最小
    }
}
///   1-(1)-2-(2)-3-(4)-4-(14)-5-
///   |                         |
///   |---------(9)-------------|

猜你喜欢

转载自blog.csdn.net/qq_43813697/article/details/90905523