问题 A: Least Common Multiple

题目链接http://codeup.cn/problem.php?cid=100000589&pid=0

题目描述
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

输入
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 … nm where m is the number of integers in the set and n1 … nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

输出
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

样例输入
2
2 3 5
3 4 6 12

样例输出
15
12

代码

#include<stdio.h>

int gcd(int a, int b) {
	if(b == 0)
		return a;
	else
		return gcd(b, a % b);
}

int main() {
	int m, n, a, d; 
	while(scanf("%d", &m) != EOF) {
		while(m > 0){
			m--;
			scanf("%d", &n);
			d = 1;			//第一次令d = 1
			while(n > 0) {
				n--;
				scanf("%d", &a);
				d = d / gcd(d, a) * a;
			}
			printf("%d\n", d);
		}
	}
	return 0;
}
发布了162 篇原创文章 · 获赞 7 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/Rhao999/article/details/104180612