POJ 2689【筛法求素数+区间筛素数】

Discription
The branch of mathematics called number theory is about properties of numbers. One of the areas that
has captured the interest of number theoreticians for thousands of years is the question of primality. A
prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The
first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions
is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but
there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent
primes that are also adjacent numbers.
Your program is given 2 numbers: L and U (1 ≤ L < U ≤ 2, 147, 483, 647), and you are to find the
two adjacent primes C1 and C2 (L ≤ C1 < C2 ≤ U) that are closest (i.e. C2 − C1 is the minimum). If
there are other pairs that are the same distance apart, use the first pair. You are also to find the two
adjacent primes D1 and D2 (L ≤ D1 < D2 ≤ U) where D1 and D2 are as distant from each other as
possible (again choosing the first pair if there is a tie).
Input
Each line of input will contain two positive integers, L and U, with L < U. The difference between L
and U will not exceed 1,000,000.
Output
For each L and U, the output will either be the statement that there are no adjacent primes (because
there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent
primes.
Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

题意
给定一个区间[l,r],求区间里相聚最近的两个素数。

思路
先用欧拉筛预处理1e6以内的素数,在二次筛区间[l,r]以内的素数。

AC代码

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int N = 1000005;
const int INF = 999999999;
bool notprime[N];
int prime1[N], prime2[N];
int num1, num2;

void Prime1()  // 第一次筛出46500以内的素数
{
    memset(notprime, false, sizeof(notprime));
    for(int i=2; i<N; i++)
        if(!notprime[i])
        {
            prime1[num1++] = i;
            for(int j=2*i; j<N; j+=i)
                notprime[j] = true;
        }
}

void Prime2(int l, int u)  // 第二次筛出给定范围内的素数
{
    memset(notprime, false, sizeof(notprime));
    num2=0;
    if(l<2)
        l=2;
    int k=sqrt(u*1.0);
    for(int i=0; i<num1&&prime1[i]<=k; i++)
    {
        int t=l/prime1[i];
        if(t*prime1[i]< l)
            t++;
        if(t<=1)
            t=2;
        for(int j=t; (ll)j*prime1[i]<=u; j++)  // 相乘会超范围,用long long
            notprime[j*prime1[i]-l] = 1;
    }
    for(int i=0; i<=u-l;i++)
        if(!notprime[i])
            prime2[num2++]=i+l;
}

int l, u, dis, a1, b1, a2, b2, minn, maxx;

int main()
{
    Prime1();
    while(scanf("%d%d", &l, &u) != EOF)
    {
        minn=INF, maxx=-1;
        Prime2(l, u);
        if(num2<2)
        {
            printf("There are no adjacent primes.\n");
            continue;
        }
        for(int i=1; i<num2&&prime2[i]<=u; i++)
        {
            dis=prime2[i]-prime2[i-1];
            if(dis>maxx)
            {
                a1=prime2[i-1];
                a2=prime2[i];
                maxx=dis;
            }
            if(dis<minn)
            {
                b1=prime2[i-1];
                b2=prime2[i];
                minn=dis;
            }
        }
        printf("%d,%d are closest, %d,%d are most distant.\n", b1, b2, a1, a2);
    }
    return 0;
}
发布了306 篇原创文章 · 获赞 105 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/weixin_43460224/article/details/104228138