USACO-Section 3.1-PROB Score Inflation

Score Inflation

The more points students score in our contests, the happier we here at the USACO are. We try to design our contests so that people can score as many points as possible, and would like your assistance.

We have several categories from which problems can be chosen, where a "category" is an unlimited set of contest problems which all require the same amount of time to solve and deserve the same number of points for a correct solution. Your task is write a program which tells the USACO staff how many problems from each category to include in a contest so as to maximize the total number of points in the chosen problems while keeping the total solution time within the length of the contest.

The input includes the length of the contest, M (1 <= M <= 10,000) (don't worry, you won't have to compete in the longer contests until training camp) and N, the number of problem categories, where 1 <= N <= 10,000.

Each of the subsequent N lines contains two integers describing a category: the first integer tells the number of points a problem from that category is worth (1 <= points <= 10000); the second tells the number of minutes a problem from that category takes to solve (1 <= minutes <= 10000).

Your program should determine the number of problems we should take from each category to make the highest-scoring contest solvable within the length of the contest. Remember, the number from any category can be any nonnegative integer (0, one, or many). Calculate the maximum number of possible points.

PROGRAM NAME: inflate

INPUT FORMAT

Line 1: M, N -- contest minutes and number of problem classes
Lines 2-N+1: Two integers: the points and minutes for each class

SAMPLE INPUT (file inflate.in)

300 4
100 60
250 120
120 100
35 20

OUTPUT FORMAT

A single line with the maximum number of points possible given the constraints.

SAMPLE OUTPUT (file inflate.out)

605

(Take two problems from #2 and three from #4.) 


裸裸的完全背包。。


#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
#define name "inflate"
using namespace std;
int n,m;
int c[10005],v[10005];
int dp[10005];
int main()
{
	freopen(name ".in","r",stdin);
	freopen(name ".out","w",stdout);
	cin>>m>>n;
	int i,j;
	for (i=1;i<=n;i++)
	cin>>v[i]>>c[i];
	for (i=1;i<=n;i++)
	  for (j=c[i];j<=m;j++)
	  	dp[j]=max(dp[j],dp[j-c[i]]+v[i]);
	cout<<dp[m]<<endl;
	return 0;
}
/*
Executing...
   Test 1: TEST OK [0.011 secs, 4296 KB]
   Test 2: TEST OK [0.011 secs, 4296 KB]
   Test 3: TEST OK [0.000 secs, 4296 KB]
   Test 4: TEST OK [0.000 secs, 4296 KB]
   Test 5: TEST OK [0.000 secs, 4296 KB]
   Test 6: TEST OK [0.011 secs, 4296 KB]
   Test 7: TEST OK [0.054 secs, 4296 KB]
   Test 8: TEST OK [0.162 secs, 4296 KB]
   Test 9: TEST OK [0.173 secs, 4296 KB]
   Test 10: TEST OK [0.162 secs, 4296 KB]
   Test 11: TEST OK [0.000 secs, 4296 KB]
   Test 12: TEST OK [0.000 secs, 4296 KB]

All tests OK.
YOUR PROGRAM ('inflate') WORKED FIRST TIME!  That's fantastic
-- and a rare thing.  Please accept these special automated
congratulations.
*/


发布了20 篇原创文章 · 获赞 0 · 访问量 5208

猜你喜欢

转载自blog.csdn.net/SoYouTry/article/details/50573200