USACO-Section 3.1-PROB Agri-Net

Agri-Net
Russ Cox

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.

Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.

Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.

The distance between any two farms will not exceed 100,000.

PROGRAM NAME: agrinet

INPUT FORMAT

Line 1: The number of farms, N (3 <= N <= 100).
Line 2..end: The subsequent lines contain the N x N connectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

SAMPLE INPUT (file agrinet.in)

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

OUTPUT FORMAT

The single output contains the integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

SAMPLE OUTPUT (file agrinet.out)

28
 
 
裸裸的最小生成树,用来复习prim & kruskal

#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
#define name "agrinet"
using namespace std;
int n,m,mst;
struct edge_
{
	int u,v,w;
}edge[10005];
int et,fa[105];
int find(int x)
{
	if (fa[x]!=x) fa[x]=find(fa[x]);
	return fa[x];
}
void Union(int a,int b)
{
	int x=find(a),y=find(b);
	if (x!=y) fa[x]=y;
}
void add(int u,int v,int w)
{
	et++;
	edge[et].u=u;edge[et].v=v;edge[et].w=w;
}
bool cmp(edge_ x,edge_ y)
{
	return x.w<y.w;
}
int main()
{
	freopen(name ".in","r",stdin);
	freopen(name ".out","w",stdout);
	cin>>n;
	int i,j,x;
	for (i=1;i<=n;i++)
	  for (j=1;j<=n;j++)
	  {
	  	  cin>>x;
	  	  if (i!=j) add(i,j,x);
	  }
	for (i=1;i<=n;i++)
	fa[i]=i;
	sort(edge+1,edge+1+et,cmp);
	for (i=1;i<=et;i++)
	{
		if (find(edge[i].u)!=find(edge[i].v))
		{
			Union(edge[i].u,edge[i].v);
			mst+=edge[i].w;
		}
	}
	cout<<mst<<endl;
	return 0;
}
/*
Executing...
   Test 1: TEST OK [0.000 secs, 4300 KB]
   Test 2: TEST OK [0.000 secs, 4300 KB]
   Test 3: TEST OK [0.000 secs, 4300 KB]
   Test 4: TEST OK [0.000 secs, 4300 KB]
   Test 5: TEST OK [0.000 secs, 4300 KB]
   Test 6: TEST OK [0.000 secs, 4300 KB]
   Test 7: TEST OK [0.000 secs, 4300 KB]
   Test 8: TEST OK [0.000 secs, 4300 KB]
   Test 9: TEST OK [0.011 secs, 4300 KB]
   Test 10: TEST OK [0.011 secs, 4300 KB]

All tests OK.
YOUR PROGRAM ('agrinet') WORKED FIRST TIME!  That's fantastic
-- and a rare thing.  Please accept these special automated
congratulations.
*/



发布了20 篇原创文章 · 获赞 0 · 访问量 5208

猜你喜欢

转载自blog.csdn.net/SoYouTry/article/details/50573065