USACO-Section 3.2-PROB Factorials

Factorials

The factorial of an integer N, written N!, is the product of all the integers from 1 through N inclusive. The factorial quickly becomes very large: 13! is too large to store in a 32-bit integer on most computers, and 70! is too large for most floating-point variables. Your task is to find the rightmost non-zero digit of n!. For example, 5! = 1 * 2 * 3 * 4 * 5 = 120, so the rightmost non-zero digit of 5! is 2. Likewise, 7! = 1 * 2 * 3 * 4 * 5 * 6 * 7 = 5040, so the rightmost non-zero digit of 7! is 4.

PROGRAM NAME: fact4

INPUT FORMAT

A single positive integer N no larger than 4,220.

SAMPLE INPUT (file fact4.in)

7

OUTPUT FORMAT

A single line containing but a single digit: the right most non-zero digit of N! .

SAMPLE OUTPUT (file fact4.out)

4
 
 
把每个数分解质因数
因为2*5之后会产生一个零一直在右边,所以直接把2和5的个数同时减小,直到其中一个不存在(对答案无影响)
把所有质因数边乘边模

#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
#define name "fact4"
using namespace std;
int n,ans=1;
int cnt[5000];
void fenjie(int x)
{
	int i=2;
	while (x!=0&&x!=1)
	{
		while (x%i==0) 
		{
			cnt[i]++;
			x/=i;
			if (x==0) break;
		}
		i++;
    }
}
int main()
{
	freopen(name ".in","r",stdin);
	freopen(name ".out","w",stdout);
	cin>>n;
	int i,j;
	for (i=2;i<=n;i++)
		fenjie(i);
	cnt[2]-=cnt[5];cnt[5]=0;
	for (i=2;i<=n;i++)
	{
		for (j=1;j<=cnt[i];j++)
		ans=(ans*i)%10;
	}
	cout<<ans<<endl;
	return 0;
}
/*
Executing...
   Test 1: TEST OK [0.000 secs, 4196 KB]
   Test 2: TEST OK [0.000 secs, 4196 KB]
   Test 3: TEST OK [0.000 secs, 4196 KB]
   Test 4: TEST OK [0.000 secs, 4196 KB]
   Test 5: TEST OK [0.000 secs, 4196 KB]
   Test 6: TEST OK [0.000 secs, 4196 KB]
   Test 7: TEST OK [0.000 secs, 4196 KB]
   Test 8: TEST OK [0.000 secs, 4196 KB]
   Test 9: TEST OK [0.000 secs, 4196 KB]
   Test 10: TEST OK [0.000 secs, 4196 KB]

All tests OK.
YOUR PROGRAM ('fact4') WORKED FIRST TIME!  That's fantastic
-- and a rare thing.  Please accept these special automated
congratulations.
*/


发布了20 篇原创文章 · 获赞 0 · 访问量 5208

猜你喜欢

转载自blog.csdn.net/SoYouTry/article/details/50575360