HDU - 2039 三角形

Description

给定三条边,请你判断一下能不能组成一个三角形。

Input

输入数据第一行包含一个数M,接下有M行,每行一个实例,包含三个正数A,B,C。其中A,B,C <1000;

Output

对于每个测试实例,如果三条边长A,B,C能组成三角形的话,输出YES,否则NO。

Sample Input

2
1 2 3
2 2 2

Sample Output

NO
YES
#include <iostream>
#include <cstdio>

using namespace std;

int main()
{
	int n;
	double a, b, c;

	scanf("%d", &n);
	while (n--)
    {
        scanf("%lf%lf%lf", &a, &b, &c);
        if (a + b > c && a + c > b && b + c > a) // 任意两边之和大于第三边
            printf ("YES\n");
        else
            printf ("NO\n");
    }
	return 0;
}
发布了329 篇原创文章 · 获赞 342 · 访问量 17万+

猜你喜欢

转载自blog.csdn.net/Aibiabcheng/article/details/105321374
今日推荐