HDU - 2039三角形 ————计算几何

给定三条边,请你判断一下能不能组成一个三角形。
Input
输入数据第一行包含一个数M,接下有M行,每行一个实例,包含三个正数A,B,C。其中A,B,C <1000;
Output
对于每个测试实例,如果三条边长A,B,C能组成三角形的话,输出YES,否则NO。
Sample Input
2
1 2 3
2 2 2
Sample Output
NO
YES


注意一下数据类型要用double就好了

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;


int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        double a,b,c;
        scanf("%lf %lf %lf",&a,&b,&c);
        double sum=a+b+c;
        double x=max(a,max(b,c));
        if(2*x>=sum)    printf("NO\n");
        else        printf("YES\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Hpuer_Random/article/details/81350693
今日推荐