Max Sum(局部最大和)

题目出处(点击)
Problem Description
Given a sequence a[1],a[2],a[3]…a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output
Case 1:
14 1 4

Case 2:
7 1 6
题意:
就是找出数组中某一段和为这个数组局部最大和
思路
法1.假设我们已经求出以n-1为结尾的局部最大和,那现在是不是只需判断,a[n]是否大于0,如果大于0,那就加入前一个的dp,由此可以总结出,动态转移方程dp[i] = max (a[i],dp[i-1]+a[i])。下面代码就是法一。

法2.我们先求出1到n的这些序列的所有和sum[1,2,3…n]。假设我们已经求出前n-1项的和,现在要求以第n项为结尾的局部最大和dp[n]是不是用这个sum[n] - n以前的一个最小的sum[i],可以发现这就是以n为范围结尾的局部最大和。

#include <iostream>
#include <cstring>
#define max(a,b) (a)>(b)?(a):(b)//在自己的编译器这个可以省略,但是在hdu上省略就会报编译错误
using namespace std;

#define maxn 100010

int a[maxn];	//数组
int dp[maxn];	//局部最大和

int main()
{
    int t,n,sum,amax,icase=0,src,dest;
    cin>>t;
    while(t--)
    {
        cin>>n;
        memset(a,0,sizeof(a));
        memset(dp,0,sizeof(dp));
        sum=0,amax=-1001;	//sum就是辅助求解,amax记录最大的那个局部最大和
        for(int i=1;i<=n;i++)
        {
            cin>>a[i];
            dp[i]=max(a[i],dp[i-1]+a[i]);
            if(amax < dp[i])		//判断一下,是否需要更新amax
            {
                amax=dp[i];
                dest=i;
            }
        }
        for(int i=dest;i>=1;i--)		//计算最大和的起始位置 
        {
            sum+=a[i];
            if(sum==amax) src=i;
        }
        cout<<"Case "<<++icase<<":"<<endl;
        cout<<amax<<" "<<src<<" "<<dest<<endl;
        if(t!=0) cout<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_46687179/article/details/105622445