Max Sum - 最大连续子序

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14. 
InputThe first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000). 
OutputFor each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases. 
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4

Case 2:
7 1 6

分析:

动态规划:状态转移方程:sum[i]=max{sum[i-1]+a[i],a[i]}也就是要a[i]和不要a[i]的区别

sum[i]表示到第i位,最大连续子序大小,负数的情况也可以

代码如下:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<string>
#include<queue>
#include<vector>
using namespace std;

int main(){
    int t,n;
    scanf("%d",&t);
    for(int q=1;q<=t;q++){
        if(q>1)printf("\n");
        scanf("%d",&n);
        int mymax=-1001,sum=-1001,a,b,A,B,tmp;

        for(int i=1;i<=n;i++){
            scanf("%d",&tmp);
            if(sum+tmp<tmp){
                sum=tmp;a=b=i;
            }
            else{
                sum+=tmp;b=i;
            }
            if(mymax<sum){
                mymax=sum;
                A=a;B=b;
            }
        }
        printf("Case %d:\n",q);
        printf("%d %d %d\n",mymax,A,B);
    }
}


猜你喜欢

转载自blog.csdn.net/m0_37579232/article/details/80294758