PAT甲级1001 A+B Format (20分)

#PAT甲级1001 A+B Format (20分)

题目:Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b
​​ . The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

第一题解题思路:输入int 型变量a与b,将a与b相加赋给c,如果c小于0则输出一个负号,将结果利用to-string函数变为字符串形式s,然后将该字符串逆置,用s1字符串存储答案,对于s的逆序进行遍历,每隔三个字符输出一个‘,’,若最后一个字符序号恰好为3的整数倍,则不用输出‘,’,最后将s1逆置回来,输出s1。

AC代码附上:

#include <iostream>
#include <algorithm>
using namespace std;

int main(){
    
    
    int a,b,c;
    string s,s1="";
    cin>>a>>b;
    c=a+b;
    if(c<0){
    
    
        cout<<"-";
        c=-c;
    }
    s=to_string(c);
    reverse(s.begin(),s.end());
    for(int i=0;i<s.length();i++){
    
    
        s1+=s[i];
       if((i+1)%3==0&&(i!=s.length()-1)){
    
    
           s1+=',';
       }


    }
    reverse(s1.begin(),s1.end());
    cout<<s1;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43795683/article/details/104251408