PAT 甲级 1001 A+B Format (20分)

题目

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​ ≤a,b≤10​6​​ . The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

Code:

#include<iostream>
#include<math.h>
using namespace std;

int main(){
    
    
	int a,b,count=0;
	scanf("%d %d",&a,&b);
	int sum=a+b;
	char result[20];
		
	if(sum==0) cout<<"0";
	else{
    
    
		if(sum<0){
    
    
			cout<<"-";
			sum=(-1)*sum;
		}
	
		int i=1;
		while(sum>0){
    
    
			result[i]=(sum%10)+'0';
			sum/=10;
			i++;
			if(i%4==0&&sum!=0){
    
    
				result[i]=',';
				i++;
			}
		}
	
		for(int j=(i-1);j>=1;j--)
			cout<<result[j];
	
	}
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/HHCCCaptain/article/details/109718190