PAT-1023 Have Fun with Numbers

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

思路

long long型只能存19数字,所以只能用字符数组存放。用size数组判断,如果全部为0,说明就是Yes,否则就是No

Code

#include <iostream>
#include <string>
using namespace std;

int size[10];
int num[24]; // 存放乘以2后的数字
int main(){
    
    
    string a;
    cin >> a;
    int index = 0;
    for(int i=a.size()-1; i>=0; i--){
    
    
        int temp = a[i]-'0';
        size[temp]++;
        num[index] += (temp * 2) %10;
        num[index+1] = (temp*2) / 10;
        index++;
    }
    if (num[index] == 0) index--;
    int flag = 0;
    for (int i=index; i>=0; i--){
    
    
        size[num[i]]--;
        if (size[num[i]] <0){
    
    
            flag = 1;
            break;
        }
    }
    if (flag == 0){
    
    
        cout << "Yes" << endl;
    }else{
    
    
        cout << "No" << endl;
    }
    for (int i = index; i>=0; i--){
    
    
        cout << num[i];
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42100456/article/details/109553196