#1098. Insertion or Heap Sort【排序】

原题链接

Problem Description:

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N N N ( ≤ 100 \leq 100 100). Then in the next line, N N N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N N N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either “Insertion Sort” or “Heap Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:

Heap Sort
5 4 3 1 0 2 6 7 8 9

Problem Analysis:

本题需要先修 堆排序插入排序 的知识。

按照题目要求找出两段区间的分界点,然后进行下一轮迭代即可。

注意其中插入排序满足严格的两段性,即前半段是完成排序的区间,后半段是未完成排序且与原数组位置保持一致的区间。

Code

#include <iostream>
#include <cstring>
#include <algorithm>

using namespace std;

const int N = 110;

int n;
int a[N], b[N];

void down(int u, int size)
{
    
    
    int t = u;
    if (u * 2 <= size && b[t] < b[u * 2]) t = u * 2;
    if (u * 2 + 1 <= size && b[t] < b[u * 2 + 1]) t = u * 2 + 1;
    if (t != u)
    {
    
    
        swap(b[t], b[u]);
        down(t, size);
    }
}

int main()
{
    
    
    cin >> n;
    for (int i = 1; i <= n; i ++ ) cin >> a[i];
    for (int i = 1; i <= n; i ++ ) cin >> b[i];
    
    int p = 2;
    while (p <= n && b[p] >= b[p - 1]) p ++ ;
    
    int k = p;  // k为第一个不满足升序的下标位置
    while (p <= n && a[p] == b[p]) p ++ ;  // 如果后半段满足和原序列一致,则为插入排序
    if (p == n + 1)
    {
    
    
        puts("Insertion Sort");
        while (k > 1 && b[k] < b[k - 1]) swap(b[k], b[k - 1]), k -- ;   
    }
    else
    {
    
    
        // 0, 1, 2, ..., n - 1
        puts("Heap Sort");
        p = n;
        while (b[1] <= b[p]) p -- ;  // 找到第一个比堆顶元素小的,交换,
        swap(b[1], b[p]);
        down(1, p - 1);
    }
    
    cout << b[1];
    
    for (int i = 2; i <= n; i ++ ) cout << ' ' << b[i];
    cout << endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/geraltofrivia123/article/details/121456711