1098. Insertion or Heap Sort (25)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/zs391077005/article/details/79116636


时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. At each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0
Sample Output 1:
Insertion Sort
1 2 3 5 7 8 9 4 6 0
Sample Input 2:
10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9
Sample Output 2:
Heap Sort
5 4 3 1 0 2 6 7 8 9

提交代码

#include<fstream>
#include <cstdio>
#include <iostream>
#include<algorithm>
#include<set>
#include<map>
#include<vector>
#include<string>
#include<cmath>
#include<stack>
using namespace std;
vector<int > a,b;
void downAdjust(int low,int high)
{
	int i=1,j=i*2;
	while(j<=high)
	{
		if(j+1<=high&&b[j]<b[j+1])
		j=j+1;
		if(b[i]<b[j])
		{
			swap(b[i],b[j]);
			i=j;j=i*2;
		}
		else break;
	}
}


int main()
{
	int n;
	cin>>n;
	a.resize(n+1);b.resize(n+1);
	for(int i=1;i<=n;i++)
	{
		scanf("%d",&a[i]);
	}
	for(int i=1;i<=n;i++)
	{
		scanf("%d",&b[i]);
	}
	int p=2;
	while(p<=n&&b[p-1]<=b[p]) p++;
	int index=p;
	while(p<=n&&a[p]==b[p]) p++;
	if(p==n+1)
	{
		printf("Insertion Sort\n");
		sort(b.begin()+1,b.begin()+index+1);
	}
	else
	{
		printf("Heap Sort\n");
		p=n;
		while(b[p]>b[p-1]&&p>=1) p--;
		swap(b[p],b[1]);
		downAdjust(1,p-1);
		
	}


	for(int i=1;i<=n;i++)
	{
		if(i!=n)
		printf("%d ",b[i]);
		else printf("%d",b[i]);
	}

#ifdef _DEBUG
	system("pause");
#endif	


	return 0;
	
}


猜你喜欢

转载自blog.csdn.net/zs391077005/article/details/79116636