1098. Insertion or Heap Sort (25)【排序】——PAT (Advanced Level) Practise

版权声明:本文为博主原创文章,转载请标明出处 http://blog.csdn.net/xianyun2009 https://blog.csdn.net/xianyun2009/article/details/51407868

题目信息

1098. Insertion or Heap Sort (25)

时间限制100 ms
内存限制65536 kB
代码长度限制16000 B

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either “Insertion Sort” or “Heap Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0
Sample Output 1:
Insertion Sort
1 2 3 5 7 8 9 4 6 0
Sample Input 2:
10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9
Sample Output 2:
Heap Sort
5 4 3 1 0 2 6 7 8 9

扫描二维码关注公众号,回复: 3826946 查看本文章

解题思路

单步排序做测试

AC代码

#include <cstdio>
#include <algorithm>
#include <vector>
using namespace std;
int main(){
    int n, a, b;
    vector<int> va, vb, vc;
    scanf("%d", &n);
    for (int i = 0; i < n; ++i){
        scanf("%d", &a);
        va.push_back(a);
    }
    for (int i = 0; i < n; ++i){
        scanf("%d", &b);
        vb.push_back(b);
    }
    vc = va;
    int p = n;
    make_heap(vc.begin(), vc.begin() + p);
    while (vc != vb && p >= 0){
        pop_heap(vc.begin(), vc.begin() + p);
        --p;
    }
    if (vc == vb){
        printf("Heap Sort\n");
        pop_heap(vc.begin(), vc.begin() + p);
        vb = vc;
    }else{
        p = 1;
        while (p < n && vb[p - 1] <= vb[p]) ++p;
        while (p >= 0 && vb[p-1] > vb[p]){
            swap(vb[p], vb[p-1]);
            --p;
        }
        printf("Insertion Sort\n");
    }
    printf("%d", vb[0]);
    for (int i = 1; i < n; ++i){
        printf(" %d", vb[i]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xianyun2009/article/details/51407868