HDU 1029 Ignatius and the Princess IV (map的使用)

传送门:

http://acm.hdu.edu.cn/showproblem.php?pid=1029

Ignatius and the Princess IV

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32767 K (Java/Others)
Total Submission(s): 42359    Accepted Submission(s): 18467


Problem Description
"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?
 
Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
 
Output
For each test case, you have to output only one line which contains the special number you have found.
 
Sample Input
5 1 3 2 3 3 11 1 1 1 1 1 5 5 5 5 5 5 7 1 1 1 1 1 1 1
 
Sample Output
3 5 1
 
Author
Ignatius.L
 
分析:
题目意思就是统计哪个数出现的次数等于(n+1)/2
 
使用map无疑是最方便的了
 
code:
#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
#define max_v 125
int main()
{
    LL n;
    while(~scanf("%I64d",&n))
    {
        map<LL,LL> mm;
        map<LL,LL>::iterator it;
        for(LL i=1;i<=n;i++)
        {
            LL x;
            scanf("%I64d",&x);
            mm[x]++;
        }
        for(it=mm.begin();it!=mm.end();it++)
        {
            if(it->second>=(n+1)/2)
            {
                cout<<it->first<<endl;
                break;
            }
        }
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/yinbiao/p/9314605.html