数据结构实验之栈与队列十:走迷宫

数据结构实验之栈与队列十:走迷宫

Problem Description
一个由n * m 个格子组成的迷宫,起点是(1, 1), 终点是(n, m),每次可以向上下左右四个方向任意走一步,并且有些格子是不能走动,求从起点到终点经过每个格子至多一次的走法数。

Input
第一行一个整数T 表示有T 组测试数据。(T <= 110)

对于每组测试数据:

第一行两个整数n, m,表示迷宫有n * m 个格子。(1 <= n, m <= 6, (n, m) !=(1, 1) ) 接下来n 行,每行m 个数。其中第i 行第j 个数是0 表示第i 行第j 个格子可以走,否则是1 表示这个格子不能走,输入保证起点和终点都是都是可以走的。

任意两组测试数据间用一个空行分开。

Output
对于每组测试数据,输出一个整数R,表示有R 种走法。

Sample Input
3
2 2
0 1
0 0
2 2
0 1
1 0
2 3
0 0 0
0 0 0
Sample Output
1
0
4
Hint

#include <cstdio>
#include <cstring>

using namespace std;
int n,m;
int step[4][2] = {
    {0,1},{0,-1},{1,0},{-1,0}
};
int mm[10][10];
bool vis[10][10];
int cnt;
void dfs(int x,int y)
{
    if(x == n && y == m)
    {
        cnt ++;
        return ;
    }

    for(int k = 0; k < 4; k++)
    {
        int tx = x + step[k][0];
        int ty = y + step[k][1];
        if(tx<1||tx>n||ty<1||ty>m)
        {
            continue;
        }


        if(!mm[tx][ty] && !vis[tx][ty])
        {

            vis[tx][ty] = true;
            dfs(tx,ty);
            vis[tx][ty] = false;
        }
    }
}
int main(int argc, char const *argv[])
{
    int T;
    cin>>T;
    while(T--)
    {
        cnt = 0;
        cin>>n>>m;
        for (int i = 1; i <= n; ++i)
        {
            for (int j = 1; j <= m; ++j)
            {
                cin>>mm[i][j];
            }
        }
        vis[1][1] = true;
        dfs(1,1);
        cout<<cnt<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/minose/article/details/81000872