1001 A+B Format (20)(20 分)

1001 A+B Format (20)(20 分)
Calculate a + b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

分析:题目要求你计算A+B,但是从后往前每3位数字就需要用一个逗号隔开。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int num[10];
int main()
{
    int a,b,sum;
    scanf("%d%d",&a,&b);
    sum=a+b;
    if(sum<0)
    {
        printf("-");
        sum=-sum;
    }
    int len=0;
    if(sum==0) num[len++]=0;
    while(sum)
    {
        num[len++]=sum%10;
        sum/=10;
    }
    for(int k=len-1;k>=0;k--)
    {
        printf("%d",num[k]);
        if(k>0&&k%3==0) printf(",");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/hy971216/article/details/81113366