1001. A+B Format(20分)

1001. A+B Format(20分)

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

结尾无空行

Sample Output:

-999,991

结尾无空行
#include <iostream>
using namespace std;
int main()
{
    
    
    int a, b;
    cin >> a >> b;
    string s = to_string(a + b);
    int len = s.length();
    for (int i = 0; i < len; i++)
    {
    
    
        cout << s[i];
        if (s[i] == '-')
        {
    
    
            continue;
        }
        if ((len - 1 - i) % 3 == 0 && i != len - 1)
            cout << ",";
    }
    return 0;
}

我要麻了,第一题还出错,写了半小时。开始想复杂了,用了栈和整数求余。其实很简单,要注意的点就是算逗号的时候需要倒置求余。

猜你喜欢

转载自blog.csdn.net/leoabcd12/article/details/119335686