1001. A+B Format (20)

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9
Sample Output
-999,991

//正负数情况看能否分类处理,想好算法后再处理写代码
#include <stdio.h>

int main()
{
	int a,b,sum;
	while(scanf("%d %d",&a,&b) != EOF){
		sum = a+b;
		if(sum < 0){
			sum = -sum;	
			printf("-");	//转化成正数处理 
		}
		if(sum >= 1000000){
			printf("%d,%03d,%03d",sum/1000000,(sum%1000000)/1000,sum%1000);
		}
		else if(sum >= 1000){
			printf("%d,%03d",sum/1000,sum%1000);
		}
		else{
			printf("%d",sum);
		}
	}
	return 0;
}


主要是在数据输出格式的处理~水过

猜你喜欢

转载自zjuerlemon.iteye.com/blog/2239451