Cyclic Nacklace(KMP 里边fail数组的另外一个应用)

题目:https://vjudge.net/contest/243048#problem/D

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task. 

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2: 


Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden. 
CC is satisfied with his ideas and ask you for help.

Input

The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases. 
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).

Output

For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.

Sample Input

3
aaa
abca
abcde

Sample Output

0
2
5

n-fail[n]表示短字符串最小循环节的长度

其中n表示短字符串的长度

 剩下的直接套用模板。但是因为循环最少是两个所以要加判断条件m!=n

#include <iostream>
#include <stdio.h>
#include <string.h>
#define maxn 100010
using namespace std;
int fail[maxn];
char temp[maxn];
void getFail(int n) {					//n表示短字符串的长度
  int i = 0, j = -1;						//i表示短字符串当前位置,j表示当前位置之前的部分前缀和后缀相同的个数-1
	fail[0] = -1;							//fail数组表示当前位置匹配失败后从短字符串之前哪个位置继续匹配
	while(i < n) {
		if(j==-1 || temp[i]==temp[j])		//temp数组用来存储短字符串
		{
			++i, ++j;
			if(temp[i] != temp[j]) fail[i] = j;
			else fail[i] = fail[j];
		}
		else j = fail[j];
	}
}
int main()
{
    int t;
     scanf("%d",&t);
     while(t--)
     {
         scanf("%s",temp);
         int n=strlen(temp);
         getFail(n);
         int m=n-fail[n];//最小循环节的长度
         if(n%m==0&&m!=n)printf("0\n");
         else printf("%d\n",m-fail[n]%m);
     }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/guagua_de_xiaohai/article/details/81363312