ACM-ICPC 2018 南京赛区网络预赛-G Lpl and Energy-saving Lamps(线段树+打表+单点更新)

版权声明:Dream_dog专属 https://blog.csdn.net/Dog_dream/article/details/82319330

During tea-drinking, princess, amongst other things, asked why has such a good-natured and cute Dragon imprisoned Lpl in the Castle? Dragon smiled enigmatically and answered that it is a big secret. After a pause, Dragon added:

— We have a contract. A rental agreement. He always works all day long. He likes silence. Besides that, there are many more advantages of living here in the Castle. Say, it is easy to justify a missed call: a phone ring can't reach the other side of the Castle from where the phone has been left. So, the imprisonment is just a tale. Actually, he thinks about everything. He is smart. For instance, he started replacing incandescent lamps with energy-saving lamps in the whole Castle...

Lpl chose a model of energy-saving lamps and started the replacement as described below. He numbered all rooms in the Castle and counted how many lamps in each room he needs to replace.

At the beginning of each month, Lpl buys mm energy-saving lamps and replaces lamps in rooms according to his list. He starts from the first room in his list. If the lamps in this room are not replaced yet and Lpl has enough energy-saving lamps to replace all lamps, then he replaces all ones and takes the room out from the list. Otherwise, he'll just skip it and check the next room in his list. This process repeats until he has no energy-saving lamps or he has checked all rooms in his list. If he still has some energy-saving lamps after he has checked all rooms in his list, he'll save the rest of energy-saving lamps for the next month.

As soon as all the work is done, he ceases buying new lamps. They are very high quality and have a very long-life cycle.

Your task is for a given number of month and descriptions of rooms to compute in how many rooms the old lamps will be replaced with energy-saving ones and how many energy-saving lamps will remain by the end of each month.

Input

Each input will consist of a single test case.

The first line contains integers nn and m (1 \le n \le 100000, 1 \le m \le 100)m(1≤n≤100000,1≤m≤100) — the number of rooms in the Castle and the number of energy-saving lamps, which Lpl buys monthly.

The second line contains nn integers k_1, k_2, ..., k_nk1 ,k2 ,...,kn
(1 \le k_j \le 10000, j = 1, 2, ..., n)(1≤kj ≤10000,j=1,2,...,n) — the number of lamps in the rooms of the Castle. The number in position jjis the number of lamps in jj-th room. Room numbers are given in accordance with Lpl's list.

The third line contains one integer q (1 \le q \le 100000)q(1≤q≤100000) — the number of queries.

The fourth line contains qq integers d_1, d_2, ..., d_qd1 ,d2 ,...,dq
(1 \le d_p \le 100000, p = 1, 2, ..., q)(1≤dp ≤100000,p=1,2,...,q) — numbers of months, in which queries are formed.

Months are numbered starting with 11; at the beginning of the first month Lpl buys the first m energy-saving lamps.

Output

Print qq lines.

Line pp contains two integers — the number of rooms, in which all old lamps are replaced already, and the number of remaining energy-saving lamps by the end of d_pdp  month.

Hint

Explanation for the sample:

In the first month, he bought 44 energy-saving lamps and he replaced the first room in his list and remove it. And then he had 11 energy-saving lamps and skipped all rooms next. So, the answer for the first month is 1,1------11,1−−−−−−1 room's lamps were replaced already, 11 energy-saving lamp remain.

样例输入复制

5 4
3 10 5 2 7
10
5 1 4 8 7 2 3 6 4 7

样例输出复制

4 0
1 1
3 6
5 1
5 1
2 0
3 2
4 4
3 6
5 1

题解:线段树+打表 每次选取小于剩余的+每个月买的靠前的房间 然后更新值


#include<cstring>
#include<cstdio>
#include<iostream>
#include<string>
#include<queue>
#include<vector>
#include<algorithm>
#include<cmath>
#include<set>
#include<map>
#include<stack>
#include<functional>
using namespace std;
#define eb(x) emplace_back(x)
#define pb(x) push_back(x)
#define ps(x) push(x)
#define clr(a,b) memset(a,b,sizeof(a))
#define inf 0x3f3f3f3f3f3f
#define MAX_N 400000+5
#define MAX_M 25
typedef long long ll;
const ll INF=10000000000000000LL;
const ll maxn=1<<21;
typedef priority_queue<int,vector<int>,less<int> > pql;
typedef priority_queue<int,vector<int>,greater<int> >pqg;
int n,m,sum,room[MAX_N],res[MAX_N];
int tree[MAX_N*4],l[MAX_N*4],r[MAX_N*4];
void build(int k,int lt,int rt)
{
    l[k]=lt;r[k]=rt;
    if(lt==rt)
    {
        scanf("%d",&tree[k]);
        sum+=tree[k];
        return ;
    }
    int mind=(lt+rt)/2;
    build(k<<1,lt,mind);
    build(k<<1|1,mind+1,rt);
    tree[k]=min(tree[k<<1],tree[k<<1|1]);
    return ;
}
void update(int k)//更新值
{
    int f=k/2;
    tree[k]=inf;
    while(f)
    {
        tree[f]=min(tree[f<<1],tree[f<<1|1]);
        f/=2;
    }
    return ;
}
int query(int k,int cur)
{
    if(l[k]==r[k])
    {
        if(tree[k]<=cur)
            return k;
        else
            return 0;
    }
    if(tree[k<<1]<=cur){return query(k<<1,cur);}
    else if(tree[k<<1|1]<=cur){return query(k<<1|1,cur);}
    return 0;
}
int main()
{
#ifndef ONLINE_JUDGE
    freopen("data.txt","r",stdin);
#endif
    clr(tree,0);
    sum=0;
    scanf("%d%d",&n,&m);
    build(1,1,n);
	res[0] = 0;room[0] = 0;
    for(int i=1;i<=MAX_N;i++)
    {
       int tr=res[i-1]+m,tm=0;
	   room[i] = room[i - 1];
	   if (room[i] >= n) { res[i] = res[i - 1];continue; }
       while((tm=query(1,tr))&&tm)
       {
		   room[i]++;
           tr-=tree[tm];
           update(tm);
       }
       res[i]=tr;
    }
	int q;
	scanf("%d", &q);
	for (int i = 0;i < q;i++)
	{
		int d;
		scanf("%d", &d);
		printf("%d %d\n", room[d], res[d]);
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Dog_dream/article/details/82319330