带权并查集-------I - Navigation Nightmare

Farmer John’s pastoral neighborhood has N farms (2 <= N <= 40,000), usually numbered/labeled 1…N. A series of M (1 <= M < 40,000) vertical and horizontal roads each of varying lengths (1 <= length <= 1000) connect the farms. A map of these farms might look something like the illustration below in which farms are labeled F1…F7 for clarity and lengths between connected farms are shown as (n):

Being an ASCII diagram, it is not precisely to scale, of course.

Each farm can connect directly to at most four other farms via roads that lead exactly north, south, east, and/or west. Moreover, farms are only located at the endpoints of roads, and some farm can be found at every endpoint of every road. No two roads cross, and precisely one path
(sequence of roads) links every pair of farms.

FJ lost his paper copy of the farm map and he wants to reconstruct it from backup information on his computer. This data contains lines like the following, one for every road:

There is a road of length 10 running north from Farm #23 to Farm #17
There is a road of length 7 running east from Farm #1 to Farm #17

As FJ is retrieving this data, he is occasionally interrupted by questions such as the following that he receives from his navigationally-challenged neighbor, farmer Bob:

What is the Manhattan distance between farms #1 and #23?

FJ answers Bob, when he can (sometimes he doesn’t yet have enough data yet). In the example above, the answer would be 17, since Bob wants to know the “Manhattan” distance between the pair of farms.
The Manhattan distance between two points (x1,y1) and (x2,y2) is just |x1-x2| + |y1-y2| (which is the distance a taxicab in a large city must travel over city streets in a perfect grid to connect two x,y points).

When Bob asks about a particular pair of farms, FJ might not yet have enough information to deduce the distance between them; in this case, FJ apologizes profusely and replies with “-1”.
Input

  • Line 1: Two space-separated integers: N and M

  • Lines 2…M+1: Each line contains four space-separated entities, F1,

    F2, L, and D that describe a road. F1 and F2 are numbers of

    two farms connected by a road, L is its length, and D is a

    character that is either ‘N’, ‘E’, ‘S’, or ‘W’ giving the

    direction of the road from F1 to F2.

  • Line M+2: A single integer, K (1 <= K <= 10,000), the number of FB’s

queries

  • Lines M+3…M+K+2: Each line corresponds to a query from Farmer Bob

    and contains three space-separated integers: F1, F2, and I. F1

    and F2 are numbers of the two farms in the query and I is the

    index (1 <= I <= M) in the data after which Bob asks the

    query. Data index 1 is on line 2 of the input data, and so on.
    Output

  • Lines 1…K: One integer per line, the response to each of Bob’s

queries. Each line should contain either a distance

measurement or -1, if it is impossible to determine the

appropriate distance.

Sample Input
7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S
3
1 6 1
1 4 3
2 6 6
Sample Output
13
-1
10
Hint
At time 1, FJ knows the distance between 1 and 6 is 13.
At time 3, the distance between 1 and 4 is still unknown.
At the end, location 6 is 3 units west and 7 north of 2, so the distance is 10.

原先以为每个点需要求坐标,其实用两个权即可,其中一个代表在x轴的偏移量,另外一个代表在y轴的偏移量,这样一想就很简单了。。。。。
合并的时候:
在这里插入图片描述
一般带权并查集的根节点合并时是利用向量法,真的用两个权表示,真的就好多了。。。很多时候就是想不到

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
#include<queue>
#include<cmath>
using namespace std;
typedef long long LL;
const int inf = 0x3f3f3f3f;
const double PI = acos(-1);
const double eps = 1e-8;
#define pb push_back
#define mp make_pair
#define fi first
#define se second
const int N = 40005;

int b[N],disx[N],disy[N];
typedef struct Node{
    int u,v,w;
    char s[5];
}Node;
Node node[N];

int join(int x)
{
    int k = b[x];
    if(b[x] != x){
        b[x] = join(b[x]);
        disx[x] += disx[k];
        disy[x] += disy[k];
    }
    return b[x];
}

void unin(int u,int v,int x,int y)
{
    int tx = join(u);
    int ty = join(v);
    if(tx != ty){
        b[ty] = tx;
        disx[ty] = disx[u] - disx[v] + x;
        disy[ty] = disy[u] - disy[v] + y;
    }
}

int main()
{
    int n,m;
    while(~scanf("%d %d",&n,&m))
    {
        memset(disx,0,sizeof(disx));
        memset(disy,0,sizeof(disy));
        for(int i = 1;i <= n;++i){
            b[i] = i;
        }
        for(int i = 1;i <= m;++i){
            scanf("%d %d %d %s",&node[i].u,&node[i].v,&node[i].w,node[i].s);
        }
        int q;
        scanf("%d",&q);
        int k = 1;
        while(q--)
        {
            int u,v,t;
            scanf("%d %d %d",&u,&v,&t);
            for(int i = k;i <= t;++i){
                int dx = 0,dy = 0;
                switch(node[i].s[0]){
                    case 'E':dx += node[i].w;break;
                    case 'W':dx -= node[i].w;break;
                    case 'N':dy += node[i].w;break;
                    case 'S':dy -= node[i].w;break;
                }
                unin(node[i].u,node[i].v,dx,dy);
            }
            k = t + 1;
            int tx = join(u);
            int ty = join(v);
            if(tx != ty){
                printf("-1\n");
            }else{
                printf("%d\n",abs(disx[u] - disx[v]) + abs(disy[u] - disy[v]));
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36386435/article/details/83041247
今日推荐