HUST 1010 The Minimum Length (kmp求最小循环节)

题目描述
There is a string A. The length of A is less than 1,000,000. I rewrite it again and again. Then I got a new string: AAAAAA...... Now I cut it from two different position and get a new string B. Then, give you the string B, can you tell me the length of the shortest possible string A.For example, A="abcdefg". I got abcdefgabcdefgabcdefgabcdefg.... Then I cut the red part: efgabcdefgabcde as string B. From B, you should find out the shortest A.
输入
Multiply Test Cases.For each line there is a string B which contains only lowercase and uppercase charactors.The length of B is no more than 1,000,000.
输出
For each line, output an integer, as described above.
样例输入
bcabcab
efgabcdefgabcde
样例输出
3
7
 

#include<bits/stdc++.h>
using namespace std;
char st[1000100];
int next[1001000];
void getnext(char st[],int m)
{
    int j = 0 ,k = -1;
    next[0] = -1;
    while (j < m)
    {
        if (k == -1 || st[j] == st[k] )
        {
            ++j;
            ++k;
            next[j] = k;
        }
        else
        {
            k = next[k];
        }
       // printf("%d",next[j]);
        //printf("fgdfgdgd\n");
    }
}
int main()
{
    while (cin >> st)
    {
        int len = strlen(st);
        getnext(st,len);
        if(len == 1)
            printf("1\n");

        printf("%d\n",len - next[len]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lanshan1111/article/details/84899485