hdu 1358 kmp 最小循环节

Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16473    Accepted Submission(s): 7664


http://acm.hdu.edu.cn/showproblem.php?pid=1358

Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 
Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 
Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 
Sample Input
3 aaa 12 aabaabaabaab 0
 
Sample Output
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4
 
#include<cstdio>
#include<cstring>
const int maxn=1e6+3;
int next[maxn];
char str[maxn];
int len;
void getnext(){
    next[0]=-1;
    int k=-1;
    int j=0;
    while(j<len){
        if(k==-1||str[j]==str[k]){
            k++;
            j++;
            next[j]=k;
            
        }else{
            k=next[k];
            
        }
    //    printf("%d\n",k);
    }
    return;
}
int main(){
    
    int cnt=0;
    while(scanf("%d",&len)&&len!=0){
        //getchar();
    //    printf("%d\n",len);
     
        scanf("%s",str);
    //    printf("%s\n",str);
        
        printf("Test case #%d\n",++cnt);
        getnext();
        for(int i=2;i<=len;i++){ 
            
            int temp=i-next[i];
            if(i%temp==0&&next[i]!=0){
                printf("%d %d\n",i,i/temp);
            //    printf("%d\n",temp);
            }else{
                continue;
            }
        }
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/qqshiacm/p/11581050.html