[KMP nx数组循环节] E - Period HDU - 1358

Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12695    Accepted Submission(s): 5948


 

Problem Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

 

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.

 

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

 

Sample Input

 

3

aaa

12

aabaabaabaab

0

 

Sample Output

 

Test case #1

2 2 3 3

Test case #2

2 2 6 2 9 3 12 4

#include <bits/stdc++.h>
using namespace std;

const int mn = 1000010;

int n;
char a[mn];
int nx[mn];

void cal_next(char b[])
{
	nx[0] = -1;
	int k = -1;
	for (int i = 1; i <= n - 1; i++)
	{
		while (k > -1 && b[k + 1] != b[i])
			k = nx[k];
		if (b[k + 1] == b[i])
			k++;
		nx[i] = k;
	}
}

int main()
{
	#ifndef ONLINE_JUDGE
		freopen("D:\\in.txt", "r", stdin);
	#endif // ONLINE_JUDGE
	
	int cnt = 0;
	while (~scanf("%d", &n))
	{
		if (n == 0)
			break;
		scanf("%s", a);
		printf("Test case #%d\n", ++cnt);
		
		cal_next(a);
		
		for (int i = 0; i < n; i++)
		{
			if (nx[i] == -1)
				continue;
				
			int len = i + 1 - (nx[i] + 1);
			if ((i + 1) % len == 0) // 可由循环节组成
				printf("%d %d\n", i + 1, (i + 1) / len);
		}
		
		printf("\n");
	}
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ummmmm/article/details/81841951
今日推荐