HDU - 1358 Period kmp next数组求循环节

题目链接:点击查看

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K. 

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it. 

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case. 

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

题意:前缀数组是否有循环节,求循环节的位置以及循环了多少次

题解:next数组的应用,前i个字符循环节的长度 即为i+1-nex[i+1]  若nex[i+1]=0,也可视为没有循环节

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm> 
using namespace std;
const int N=1000010;
int n,nex[N];
char s[N];
void getnex()
{
	int i=0,j=-1;
	nex[0]=-1;
	while(i<n)
	{
		if(j==-1||s[i]==s[j])
			nex[++i]=++j;
		else j=nex[j];
	}
}
int main()
{
	int nn=1;
	while(~scanf("%d",&n)&&n)
	{
		scanf("%s",s);
		getnex();
		printf("Test case #%d\n",nn++);
		for(int i=1;i<n;i++)
		{
			int tmp=i+1-nex[i+1];
			if((i+1)%tmp==0&&nex[i+1])
				printf("%d %d\n",i+1,(i+1)/tmp); 
		}
		printf("\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/mmk27_word/article/details/86715246