PAT 甲级 1104 Sum of Number Segments

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/a845717607/article/details/87874086

1104 Sum of Number Segments (20 point(s))

Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence { 0.1, 0.2, 0.3, 0.4 }, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) and (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 10​5​​. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

Output Specification:

For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

Sample Input:

4
0.1 0.2 0.3 0.4

Sample Output:

5.00

经验总结:

这一题,就是纯粹的找规律了。。。不过找不到规律也不要紧,可以直接暴力枚举,至少可以通过前两个测试点,得到15分,不过还要注意,找到规律,写公式的时候  v*i*(n+1-i)  这里千万别写成 v*(i* (n+1-i)) ,否则也只能通过前两个测试点,主要原因,猜测是这一题可能依赖浮点运算的精度,如果先计算后面两个,可能导致最后计算结果有些许误差,和判题机所给答案不同而判错,注意一下就好~

AC代码

#include <cstdio>
int n;
int main()
{
	scanf("%d",&n);
	double ans=0,t;
	for(int i=1;i<=n;++i)
	{
		scanf("%lf",&t);
		ans+=t*i*(n+1-i);
	}
	printf("%.2f\n",ans);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/a845717607/article/details/87874086
今日推荐