畅通工程续 HDU - 1874 (最短路模板题)

畅通工程续 HDU - 1874

某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。

现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。

Input

本题目包含多组数据,请处理到文件结束。
每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。
接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。
再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。

Output

对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.

Examples

Sample Input
3 3
0 1 1
0 2 3
1 2 1
0 2
3 1
0 1 1
1 2
Sample Output
2
-1




题意:

就强调一句话: 每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择

题解:

dijkstra模板+判断一下是不是更短的路即可


#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <queue>
using namespace std;
#define ms(x, n) memset(x,n,sizeof(x));
typedef  long long LL;
const LL maxn = 210;
const int inf = 1<<30;

int V, E, S, T, G[maxn][maxn];

int d[maxn];
bool used[maxn];
typedef pair<int, int> P; //d,i
void dijkstra(int s){
    fill(d, d+V, inf);
    ms(used, 0);
    priority_queue<P, vector<P>, greater<P> > q;

    q.push(P(d[s]=0, s));
    while(!q.empty()){
        P cur = q.top();
        q.pop();
        if(used[cur.second]) continue;
        used[cur.second] = true;
        for(int i = 0; i < V; i++){
            if(d[i] > d[cur.second]+G[cur.second][i]){
                d[i] = d[cur.second]+G[cur.second][i];
                q.push(P(d[i], i));
            }
        }
    }
}
int main()
{
    while(cin >> V >> E){
        int a, b, x;
        fill_n(G[0], maxn*maxn, inf);
        for(int i = 1; i <= E; i++){
            cin >> a >> b >> x;
            G[a][b] = G[b][a] = min(G[a][b], x);
        }
        cin >> S >> T;
        dijkstra(S); //判断
        if(d[T]!=inf) cout << d[T] << endl;
        else cout << "-1" << endl;
    }

	return 0;
}


猜你喜欢

转载自blog.csdn.net/a1097304791/article/details/87924724