HDU1874:畅通工程续(最短路 floyd模板)

畅通工程续
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 77262 Accepted Submission(s): 29758

Problem Description
某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。

现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。

Input
本题目包含多组数据,请处理到文件结束。
每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。
接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。
再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。

Output
对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.

Sample Input
3 3
0 1 1
0 2 3
1 2 1
0 2
3 1
0 1 1
1 2

Sample Output
2
-1

室友熬夜打只狼,我崩溃了,只能刷刷模板题练练手速了。

这道题就是最短路的模板题,我写的是floyd。(别忘了每次开始要初始化数组嗷)

下面附上ac代码:

//AC PLZ!!!!!  :)
#include <bits/stdc++.h>
#include <stdio.h>
#include <iostream>
#include <string.h>
#include <algorithm>
#include <ctype.h>
#include <cstdlib>
#include <cmath>
#include <queue>
#include <time.h>
#include <stdlib.h>
#include <map>
//#include <sys/time.h>
//#include <unistd.h>
using namespace std;
#define INF 0x3f3f3f3f
#define MOD 1
#define mod(x) ((x) % MOD)
#define maxn 2000010
typedef long long int ll;
int mp[210][210];
int n, m, a, b, x, s, t;
void init() {
    for(int i = 0; i < n; i++) {
        for(int j = 0; j < n; j++) {
            mp[i][j] = INF;
        }
        mp[i][i] = 0;
    }
}
void floyd() {
    for(int k = 0; k < n; k++) {
        for(int i = 0; i < n; i++) {
            for(int j = 0; j < n; j++) {
                if(mp[i][j] > mp[i][k] + mp[k][j]) {
                    mp[i][j] = mp[i][k] + mp[k][j];
                }
            }
        }
    }
    return;
}
int main() {
    while(~scanf("%d%d", &n, &m)) {
        init();
        for(int i = 0; i < m; i++) {
            scanf("%d%d%d", &a, &b, &x);
            if(mp[a][b] > x) {
                mp[a][b] = mp[b][a] = x;
            }
        }
        floyd();
        scanf("%d%d", &s, &t);
        if(mp[s][t] < INF) {
            printf("%d\n", mp[s][t]);
        } else {
            printf("-1\n");
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43555854/article/details/88810426