最长公共子序列 LCS(dp)

详见:https://blog.csdn.net/someone_and_anyone/article/details/81044153

结论

在这里插入图片描述

例题

Common Subsequence HDU - 1159
https://vjudge.net/problem/HDU-1159
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, …, xm> another sequence Z = <z1, z2, …, zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, …, ik> of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Input
abcfbc abfcab
programming contest
abcd mnp
Output
4
2
0
Sample Input
abcfbc abfcab
programming contest
abcd mnp
Sample Output
4
2
0

代码
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char a[1005],b[1005];
int dp[1005][1005];
int main() {
    while(~scanf("%s %s", a, b)){
        memset(dp,0,sizeof(dp));
        int lina=strlen(a);
        int linb=strlen(b);
        for(int i=1;i<=lina;i++){
            for(int j=1;j<=linb;j++){
                if(a[i-1]==b[j-1]) dp[i][j]=max(dp[i][j],dp[i-1][j-1]+1);
            else
                dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
            }
        }
        printf("%d\n", dp[lina][linb]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_44410512/article/details/87471371
今日推荐