PAT A1103 Integer Factorization+F+DFS

1103 Integer Factorization (30 分)

The K−P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K−P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (≤400), K (≤N) and P (1<P≤7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n[1]^P + ... n[K]^P

where n[i] (i = 1, ..., K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 12​2​​+4​2​​+2​2​​+2​2​​+1​2​​, or 11​2​​+6​2​​+2​2​​+2​2​​+2​2​​, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a​1​​,a​2​​,⋯,a​K​​ } is said to be larger than { b​1​​,b​2​​,⋯,b​K​​ } if there exists 1≤L≤K such that a​i​​=b​i​​ for i<L and a​L​​>b​L​​.

If there is no solution, simple output Impossible.

Sample Input 1:

169 5 2

Sample Output 1:

169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2

Sample Input 2:

169 167 3

Sample Output 2:

Impossible

代码:

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

int n,k,p,maxFacSum=-1;
//fac是不超过n的i^p
vector<int> fac,ans,temp;

//计算x^p
int power(int x){
    int ans=1;
    for(int i=0;i<p;i++){
        ans*=x;
    }
    return ans;
}

//预处理fac数组
int init(){
    int i=0,temp=0;
    while(temp<=n){
        fac.push_back(temp);
        temp=power(++i);
    }
}

//index是fac数组的下标,nowK表示当前已经选择几个数,sum是各数的次方和,fac是各数和
void DFS(int index,int nowK,int sum,int facSum){
    if(sum==n && nowK==k){
        if(facSum>maxFacSum){ //因为从后往前选,所以不会出现facSum>maxFacSum,但temp字典序<ans的情况,所以只要facSum>maxFacSum,则是更优解
            ans=temp;
            maxFacSum=facSum;
        }
        return;
    }
    if(sum>n || nowK>k)
        return;
    if(index-1>=0){
        //选index,下一步还是让它处理index
        temp.push_back(index);
        DFS(index,nowK+1,sum+fac[index],facSum+index);
        temp.pop_back();

        //不选index,让它处理index-1
        DFS(index-1,nowK,sum,facSum);
    }
}

int main()
{
    scanf("%d%d%d",&n,&k,&p);
    init();
    DFS(fac.size()-1,0,0,0); //从后往前选
    if(maxFacSum==-1)
        cout << "Impossible\n";
    else{
        printf("%d = %d^%d",n,ans[0],p);
        for(int i=1;i<ans.size();i++){
            printf(" + %d^%d",ans[i],p);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36525099/article/details/88422566