数据结构不难之哈希表、哈希映射

第二篇 数据结构不难之哈希表、哈希映射

题目1 : Browser Caching

描述

When you browse the Internet, browser usually caches some documents to reduce the time cost of fetching them from remote servers. Let’s consider a simplified caching problem. Assume the size of browser’s cache can store M pages. When user visits some URL, browser will search it in the cache first. If the page is already cached browser will fetch it from the cache, otherwise browser will fetch it from the Internet and store it in the cache. When the cache is full and browser need to store a new page, the least recently visited page will be discarded.

Now, given a user’s browsing history please tell us where did browser fetch the pages, from the cache or the Internet? At the beginning browser’s cache is empty.
输入

Line 1: Two integers N(1 <= N <= 20000) and M(1 <= M <= 5000). N is the number of pages visited and M is the cache size.

Line 2~N+1: Each line contains a string consisting of no more than 30 lower letters, digits and dots(’.’) which is the URL of the page. Different URLs always lead to different pages. For example www.bing.com and bing.com are considered as different pages by browser.
输出

Line 1~N: For each URL in the input, output “Cache” or “Internet”.
提示

Pages in the cache before visiting 1st URL [null, null]

Pages in the cache before visiting 2nd URL [www.bing.com(1), null]

Pages in the cache before visiting 3rd URL [www.bing.com(1), www.microsoft.com(2)]

Pages in the cache before visiting 4th URL [www.bing.com(1), www.microsoft.com(3)]

Pages in the cache before visiting 5th URL [windows.microsoft.com(4), www.microsoft.com(3)]

The number in parentheses is the last visiting timestamp of the page.
样例输入

5 2
www.bing.com
www.microsoft.com
www.microsoft.com
windows.microsoft.com
www.bing.com

样例输出

Internet
Internet
Cache
Internet
Internet
#include "iostream" 
#include "string" 
#include "map" 
using namespace std; 
map<string, int> lastVist; //表示last<url[i], j> 表示最后一次访问url[i]的时间为j 
string url[20001]; 
int N, M;
int main()
{ 
	cin >> N; 
	cin >> M; 
	int i, j; 
	int s = 1; //缓存中url最早时间 
	int catchCnt = 0; 
	for(i=1; i<=N; i++) 
	{ 
		cin >> url[i]; 
		if(lastVist[url[i]] >= s) 
			cout << "Cache" << endl; 
		else 
		{ 
			catchCnt++; 
			if(catchCnt > M) // 缓存已满 
			s++; // 将该url[s]从cache中抛弃 
			cout << "Internet" << endl; 
		} 
		lastVist[url[i]] = i; // 更新最后一次访问时间
		while(lastVist[url[s]] != s) // 更新s找到新的最早的访问记录 
		s++;
	} 
  return 0; 
}

猜你喜欢

转载自blog.csdn.net/qq_44391957/article/details/88068935