HDU - 4597 Play Game (dp,记忆花搜索)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/chenshibo17/article/details/86550499

Alice and Bob are playing a game. There are two piles of cards. There are N cards in each pile, and each card has a score. They take turns to pick up the top or bottom card from either pile, and the score of the card will be added to his total score. Alice and Bob are both clever enough, and will pick up cards to get as many scores as possible. Do you know how many scores can Alice get if he picks up first?

Input

The first line contains an integer T (T≤100), indicating the number of cases. 
Each case contains 3 lines. The first line is the N (N≤20). The second line contains N integer a i (1≤a i≤10000). The third line contains N integer b i (1≤bi≤10000).

Output

For each case, output an integer, indicating the most score Alice can get.

Sample Input

2 
 
1 
23 
53 
 
3 
10 100 20 
2 4 3 

Sample Output

53 
105 

                dp[a][b][c][d]表示的是在一堆剩下[a,b]另一堆剩下[c][d]时,主角能够获得的最大值,在主角的回合,主角当然要选择最多的,在对手的回合,对手当然要选择让主角获得最少的~~

#include<bits/stdc++.h>
using namespace std;
int dp[21][21][21][21];
int v1[21], v2[21];
int n;
int cal(int a, int b, int c, int d, int kind) {
	if (a == b&&c>d)return v1[a] * kind;
	if (a>b&&c == d)return v2[c] * kind;
	if (dp[a][b][c][d] != -1)return dp[a][b][c][d];
	if (kind) {
		int ans = -1;
		if (a <= b) {
			ans = max(ans, v1[a] + cal(a + 1, b, c, d, kind ^ 1));
			ans = max(ans, v1[b] + cal(a, b - 1, c, d, kind ^ 1));
		}
		if (c <= d) {
			ans = max(ans, v2[c] + cal(a, b, c + 1, d, kind ^ 1));
			ans = max(ans, v2[d] + cal(a, b, c, d - 1, kind ^ 1));
		}
		dp[a][b][c][d] = ans;
		return ans;
	}
	else {
		int ans = 0x3f3f3f3f;
		if (a <= b) {
			ans = min(ans, cal(a + 1, b, c, d, kind ^ 1));
			ans = min(ans, cal(a, b - 1, c, d, kind ^ 1));
		}
		if (c <= d) {
			ans = min(ans, cal(a, b, c + 1, d, kind ^ 1));
			ans = min(ans, cal(a, b, c, d - 1, kind ^ 1));
		}
		dp[a][b][c][d] = ans;
		return ans;
	}
}
int main() {
	int te;
	scanf("%d", &te);
	while (te--) {
		scanf("%d", &n);
		memset(dp, -1, sizeof dp);
		for (int i = 1; i <= n; i++) {
			scanf("%d", &v1[i]);
		}
		for (int i = 1; i <= n; i++) {
			scanf("%d", &v2[i]);
		}
		cout << cal(1, n, 1, n, 1) << endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/chenshibo17/article/details/86550499
今日推荐