I Hate It HDU - 1754 (点更新,区间查询最大值)

I Hate It HDU - 1754 (点更新,区间查询最大值)

很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。
Input
本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取’Q’或’U’) ,和两个正整数A,B。
当C为’Q’的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为’U’的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。
Output
对于每一次询问操作,在一行里面输出最高成绩。
Sample Input
5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5
Sample Output
5
6
5
9

Hint
Huge input,the C function scanf() will work better than cin

题目大意:

就是有两个操作,一个是更新一个值,另一个是求一个区间内的最大值。

解题思路:

用树状数组维护区间最大值:
介绍树状数组的博客:
https://blog.csdn.net/weixin_43179892/article/details/89490577

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
const int maxn=5e5+10;
int a[maxn];
int c[maxn];
int n;
void init()
{
	memset(c,0,sizeof(c));
}
int lowbit(int x)
{
	return x&(-x);
}
void update(int x,int y,int n)//把x位置上的点改为y
{
	for(int i=x;i<=n;i+=lowbit(i))
	{
		c[i]=max(c[i],y);
	}
}

int query(int l,int r)
{
	int ans=0;
	while(l<=r)
	{
		ans=max(ans,a[r]);
		r--;
		for(; r-l>=lowbit(r); r-=lowbit(r))
		{
			ans=max(ans,c[r]);
		}
	}
	return ans;
}

int main()
{
	int n,m;
	while(~scanf("%d%d",&n,&m))
	{
		init();
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
			update(i,a[i],n);
		}
		char order;
		
		int x,y;
		while(m--)
		{
			cin>>order;
			scanf("%d%d",&x,&y);
			if(order=='Q')
				cout<<query(x,y)<<endl;
			else
			{
				a[x]=y;
				update(x,y,n);
			}
		}
	}

	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43179892/article/details/89493821