UVA - 1586:Molar mass

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/wingrez/article/details/89683178

Molar mass

来源:UVA

标签:基础

参考资料:

相似题目:

题目

An organic compound is any member of a large class of chemical compounds whose molecules contain carbon. The molar mass of an organic compound is the mass of one mole of the organic compound. The molar mass of an organic compound can be computed from the standard atomic weights of the elements.
When an organic compound is given as a molecular formula, Dr. CHON wants to find its molar mass. A molecular formula, such as C3H4O3, identifies each constituent element by its chemical symbol and indicates the number of atoms of each element found in each discrete molecule of that compound. If a molecule contains more than one atom of a particular element, this quantity is indicated using a subscript after the chemical symbol.
In this problem, we assume that the molecular formula is represented by only four elements, ‘C’ (Carbon), ‘H’ (Hydrogen), ‘O’ (Oxygen), and ‘N’ (Nitrogen) without parentheses.
The following table shows that the standard atomic weights for ‘C’, ‘H’, ‘O’, and ‘N’.
在这里插入图片描述
在这里插入图片描述
For example, the molar mass of a molecular formula C6H5OH is 94.108 g/mol which is computed by
6 × (12.01 g/mol) + 6 × (1.008 g/mol) + 1 × (16.00 g/mol).
Given a molecular formula, write a program to compute the molar mass of the formula.

输入

Your program is to read from standard input. The input consists of T test cases. The number of test
cases T is given in the first line of the input. Each test case is given in a single line, which contains
a molecular formula as a string. The chemical symbol is given by a capital letter and the length of
the string is greater than 0 and less than 80. The quantity number n which is represented after the
chemical symbol would be omitted when the number is 1 (2 ≤ n ≤ 99).

输出

Your program is to write to standard output. Print exactly one line for each test case. The line should contain the molar mass of the given molecular formula.

输入样例

4
C
C6H5OH
NH2CH2COOH
C12H22O11

输出样例

12.010
94.108
75.070
342.296

参考代码

#include<cstdio>
#include<cstring>
#define MAXN 50
int main() {
	int n;
	scanf("%d",&n);
	while(n--) {
		char A[4]= {'C','H','O','N'};
		double M[4]= {12.01,1.008,16.00,14.01};
		char str[MAXN];
		double sum=0;
		scanf("%s",str);
		for(int i=0; i<strlen(str);) {
			int j;
			for(j=0; j<4; j++) { //判断元素 
				if(str[i]==A[j])
					break;
			}
			i++;

			int judge=0;
			int num=0;
			while(str[i]>='0' && str[i]<='9') { //获取个数 
				judge=1;
				num=num*10+str[i]-'0';
				i++;
			}
			if(judge==0) num=1;

			sum+=M[j]*num;
		}
		printf("%.3f\n",sum);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/wingrez/article/details/89683178