【POJ 1733 --- Parity game】种类并查集+离散化

【POJ 1733 --- Parity game】种类并查集+离散化

题目来源:点击进入【POJ 1733 — Parity game】

Description

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers.

You suspect some of your friend’s answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.

Input

The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either even' orodd’ (the answer, i.e. the parity of the number of ones in the chosen subsequence, where even' means an even number of ones andodd’ means an odd number).

Output

There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.

Sample Input

10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd

Sample Output

3

解题思路

若x, y之间1的个数为偶数个, 那么1~x 与1~y中1的个数同奇偶性, 反之则异奇偶性, 我们可以将其理解为若输入x, y, even, 即x, y属于同种, 反之则属于不同种,

用种类并查集就可以啦…不过要注意三点, 一是数据范围1e9, 不能直接用做数组下标, 要先离散化一下,当然本题只需要用map映射下就行了; 二是输入的数据中x, y是闭区间, 不好处理, 我们可以将其化为半开区间来处理, (x-1, y]; 还有就是如果全部正确的话就输出m。

AC代码:

#include <iostream>
#include <algorithm>
#include <map>
#include <cstring>
#include <string>
using namespace std;
#define SIS std::ios::sync_with_stdio(false),cin.tie(0),cout.tie(0)
#define endl '\n'
const int MAXN = 1e4+5;
int pre[MAXN],rk[MAXN];

void init()
{
    memset(rk,0,sizeof(rk));
    for(int i=0;i<MAXN;i++)
        pre[i]=i;
}

int _find(int x)
{
    if(x==pre[x]) return x;
    int p=pre[x];
    pre[x]=_find(pre[x]);
    rk[x]^=rk[p];
    return pre[x];
}

bool unite(int a,int b,int c)
{
    int x=_find(a);
    int y=_find(b);
    if(x==y && rk[a]^rk[b]==c) return true;
    else if(x==y) return false;
    pre[x]=y;
    rk[x]=rk[a]^rk[b]^c;
    return true;
}

int main()
{
    SIS;
    int n,m,x,y,pos=0,ans=0;
    bool flag=false;
    string s;
    map<int,int> mp;
    cin >> n >> m;
    init();
    for(int i=1;i<=m;i++)
    {
        cin >> x >> y >> s;
        if(flag) continue;
        x--;
        int k=0;
        if(s[0]=='e') k=0;
        else k=1;
        if(!mp[x]) mp[x]=++pos;
        if(!mp[y]) mp[y]=++pos;
        if(!unite(mp[x],mp[y],k)) ans=i-1,flag=true;
        else if(i==m) ans=m;
    }
    cout << ans << endl;
    return 0;
}
发布了412 篇原创文章 · 获赞 135 · 访问量 4万+

猜你喜欢

转载自blog.csdn.net/qq_41879343/article/details/104164140
今日推荐