寒假练习——Repeating Decimals 【模拟】

The decimal expansion of the fraction 1/33 is 0.03, where the 03 is used to indicate that the cycle 03 repeats indefinitely with no intervening digits. In fact, the decimal expansion of every rational number (fraction) has a repeating cycle as opposed to decimal expansions of irrational numbers, which have no such repeating cycles.

Examples of decimal expansions of rational numbers and their repeating cycles are shown below. Here, we use parentheses to enclose the repeating cycle rather than place a bar over the cycle.

Write a program that reads numerators and denominators of fractions and determines their repeating cycles.

For the purposes of this problem, define a repeating cycle of a fraction to be the first minimal length string of digits to the right of the decimal that repeats indefinitely with no intervening digits. Thus for example, the repeating cycle of the fraction 1/250 is 0, which begins at position 4 (as opposed to 0 which begins at positions 1 or 2 and as opposed to 00 which begins at positions 1 or 4). 

Input

Each line of the input file consists of an integer numerator, which is nonnegative, followed by an integer denominator, which is positive. None of the input integers exceeds 3000. End-of-file indicates the end of input. 

Output

For each line of input, print the fraction, its decimal expansion through the first occurrence of the cycle to the right of the decimal or 50 decimal places (whichever comes first), and the length of the entire repeating cycle. In writing the decimal expansion, enclose the repeating cycle in parentheses when possible. If the entire repeating cycle does not occur within the first 50 places, place a left parenthesis where the cycle begins — it will begin within the first 50 places — and place ‘...)’ after the 50th digit.

测试样例:

Sample Input
76 25
5 43
1 397

Sample Output
76/25 = 3.04(0)
1 = number of digits in repeating cycle
5/43 = 0.(116279069767441860465)
21 = number of digits in repeating cycle
1/397 = 0.(00251889168765743073047858942065491183879093198992...)
99 = number of digits in repeating cycle

 题目大意:给定分子和分母,计算结果,将循环的部分用括号括起来(如果循环部分超过50位,则50位以后的用...表示)。还要输出循环部分是多少位。

思路:double精度不够,模拟除法计算过程,当一个余数出现第二次,说明一次循环结束。

AC代码:

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
using namespace std;
const int maxn=3005;
int a[maxn];    //结果
int b[maxn];    //储存余数
int vis[maxn];  //标记余数
int m,n;
int main()
{
    while(~scanf("%d%d",&m,&n))
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(vis,0,sizeof(vis));
        printf("%d/%d = %d.",m,n,m/n);
        int cnt=1,mark=0;
        m=m%n;
        while(m&&!vis[m])  //未被整除或未出现相同余数(即未结束一次循环)
        {
            vis[m]++;    //标记余数,当第二次出现说明一次循环结束
            b[cnt]=m;    //存储余数
            a[cnt++]=m*10/n;     //存储除的结果
            m=m*10%n;    //新的余数
        }
        for(int i=1;i<cnt&&i<=50;i++)  //超过50位只要前50位
        {
            if(b[i]==m)   //到达循环开始点
            {
                printf("(");
                mark=i;   //标记
            }
            printf("%d",a[i]);
        }
        if(!m)  //整除
            printf("(0");
        if(cnt>50)
            printf("...");
        printf(")\n");
        printf("   %d = number of digits in repeating cycle\n\n",m? cnt-mark:1);
    }
}
发布了35 篇原创文章 · 获赞 3 · 访问量 2647

猜你喜欢

转载自blog.csdn.net/qq_45309822/article/details/104317943