PAT 甲 1063 Set Similarity

Given two sets of integers, the similarity of the sets is defined to be N​c/N​t×100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.
Input Specification:
Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤10^4) and followed by M integ ers in the range [0,10^​9 ]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.
Output Specification:
For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.
Sample Input:
3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3
Sample Output:
50.0%
33.3%bizhi
题意:
给出N个集合,这N个集合中可能含有相同的值,然后再给出M个查询,每个查询给出两个集合的编号,然后求出两个集合元素的相同率,相同率即两个集合的交集/并集的元素个数的比值
思路:
利用set集合首先可以对输入的集合去重,然后枚举一个集合中的 元素利用find()函数看是否在另一个集合中出现
C++代码:

#include<cstdio>
#include<iostream>
#include<set>
using namespace std;
set<int> st[51];
void compare(int x,int y){
	int total=st[y].size(),same=0;
	for(set<int>::iterator it=st[x].begin();it!=st[x].end();it++){
		if(st[y].find(*it)!=st[y].end()){//返回找到元素的迭代器, 否则返回end()迭代器 
			//能找到元素
			same++; 
		}
		else{
			total++;
		}		
	}
	printf("%.1f%%\n",same*100.0/total);
}
int main(){
	int n,k,query,v,st1,st2;
	cin>>n;
	for(int i=1;i<=n;i++){
		cin>>k;
		for(int j=0;j<k;j++){
			cin>>v;
			st[i].insert(v);
		}
	}
	cin>>query;
	for(int i=0;i<query;i++){
		cin>>st1>>st2;
		compare(st1,st2);
	}
	
	return 0; 
} 
发布了72 篇原创文章 · 获赞 5 · 访问量 4437

猜你喜欢

转载自blog.csdn.net/u014424618/article/details/105146663